Upgrading cmake on Raspbian Jessie

Trying to build and install rtl-sdr from source I got this error on a Raspberry Pi 1 running Jessie:

$ cmake ../

CMake Error at CMakeLists.txt:22 (cmake_minimum_required):
CMake 3.7.2 or higher is required.  You are running version 3.6.2

Doing an ‘apt-get update’ and ‘apt-get upgrade’ is not picking up a more recent version, so following the steps here, I downloaded the required 3.7.2 version from source and followed the steps to build it: http://osdevlab.blogspot.com/2015/12/how-to-install-latest-cmake-for.html

I downloaded a .tar for the 3.7.2 version from:

https://cmake.org/files/v3.7

The build look over 2 hours, but completed successfully, and now I’m able to build rtl-sdr.

One Reply to “Upgrading cmake on Raspbian Jessie”

  1. gr now needs CMake 3.8. (instead of 3.7 as above)

    Using more recent cmake versions, such as 3.14 or later, will be very problematic and painful due to gcc dependencies. If you are staying on Jessie for some reasons, like me, I don’t recommend it.

Leave a Reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.