Resetting HP Proliant server ILO network settings from power on System Settings

As part of reorganizing of my home network and homelab setup, I’m moving everything running on my DL380 G7 server from 19.168.1.0/24 addresses to it’s own network under 10.0.0.0/24

I thought I knew what new ip and gateway settings I needed in ILO on my server, so I changed them through the web interface, only to find out the gateway was incorrect and now I could no longer access ILO remotely on my network.

Luckily from the power on System settings, you can access the ILO config if you connect a monitor and keyboard and press F8 when prompted (see detailed step by step and timings of each option here). The F8 to access ILO settings is only on the screen for about 2 seconds, so if you miss it you’ll get the System Settings menu like this:

If you get into this Setup Utility menu then you need to exit and try again.

The F8 prompt you’re looking for appears only for about 2 seconds before the HP RAID array info appear – if you see this then you’ve already missed it and you’ll need to reboot and try again:

This is the ILO menu you should see after pressing F8 when prompted:

I had previously changed the gateway so a router on my 192.168.1.0 network that was unreachable from there. Changed, now we’re ready to reboot:

Success, ILO is now accessible on 10.0.0.2!

Leave a Reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.