Adding a Silicon Power 512GB SSD to my Mac Pro 2008

TLDR; here’s the main points:

  • Restore a Time Machine backup using Recovery, not from Disk Utils from the MacOS installer
  • If an uninitialized SSD is not visible to Disk Utils, it may show up under ‘diskutils list’
  • If still not visible, put it in a USB drive enclosure where it should get detected, then initialize it

I picked up a cheap $50 512GB SSD to add to my Mac Pro 2008. I already have Windows 10 on one SSD, but decided it was time to replace the WD Blue 5000rpm drive also with an SSD. Backed up El Capitan to Time Machine, and now ready to add the new drive.

I mounted it in a Sabrent 2.5 to 3.5 caddy, and then attached to one of my drive sleds.

I’ve had good luck with new and even refurb drives over the past couple of years, this Silicon Power SSD is the first drive that’s given me issues, as it’s not visible in Disk Utils or even to ‘diskutils list’ which normally detects and lists an installed drive even though it’s not usable. Not knowing if it was the SATA connectors, I removed all my other disks, and moved it between each of the 4 slots, and no go, it was still not detected in MacOS Recovery Disk Utils, either when booted into El Cap, or in Windows 10.

First attempt to see what was going on, I tried downloading Silicon Power’s SP Toolbox software, and Windows Defender says it has a trojan:

Ok, well that’s not good. Uninstalled.

To double check that the drive could be detected on other machines I uninstalled it and moved it to a USB3 external drive enclosure. Windows 10 Disk Management now sees the disk as uninitialized, and pops up a dialog to initialize it as either MBR or GPT. Ok, picked GPT but haven’t formatted it yet. Going to now book back into MacOS Recovery to see if I can format it, and restore my TimeMachine backup. Back in a few mins.

Ok. So I have a Recovery partition that for some reason does not boot. The other option is to boot from an MacOS El Cap bootable USB flash drive and restore from Disk Utils there. I tried this and when I selected the ‘Restore…’ menu option, selected the Time Machine USB drive and the SSD as the target, I ended up restoring a copy of the content of the Time Machine backup onto the SSD, but it’s not bootable. First clue that this happened should have been from the boot menu screen when I had 2 identical orange Time Machine drive icons, and not a new silver bootable disk.

Since I don’t have a working Recovery partition to boot from where the ‘Restore from Time Machine’ option is, I went the long way round and installed El Cap from USB to the new SSD which got it bootable and with a new Recovery partition, then booted to this Recovery partition, selected the ‘Restore from Time Machine’ option, left it restoring over night, and now I have I my previously El Cap install completely transferred to the new SSD, successfully bootable and all. That took way longer than I expected, but now successfully up and running!

El Cap boot time from SSD on this 2008 Mac Pro is about 4 seconds, whereas before from a 5000rpm WD Blue it was at least a minute to get to the desktop… a HUGE improvement!

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.