DeploymentScanner timeouts on OpenShift JBoss AS7

I haven’t seen this error often on the hosted OpenShift service (only occasionally when there’d been a system update and your app doesn’t redeploy correctly once restarted), but running OpenShift Origin locally I was seeing this consistently trying to deploy a new application:

To increase the deployment scanner’s timeout setting, edit your project’s .openshift/config/standalone.xml, and find the deployment-scanner element:

…and then add this attribute to <deployment-scanner> :

The XSD schema for this element says the default value is 600 second, but the error above says it’s timing out after 60 seconds. Assuming the default value is 600, I doubled it, and this fixed my timeout issues.

This entry was posted in Tech Notes and tagged , , . Bookmark the permalink.

6 Responses to DeploymentScanner timeouts on OpenShift JBoss AS7

  1. vijaykumar.G says:

    Ya. Its working.

  2. poorna.sg says:

    I have increased to 1200 sec.Still i am having the same problem.Could you please let me know how to resolve this issue.

  3. Asvini says:

    Thanks a lot.. Its working..

  4. Palash Holkar says:

    Thanks, it worked for me.

  5. shweta says:

    hello poorna..was ur problem solved..
    even i m having the same problem..
    pls help

  6. Pingback: Unable to deploy WAR file in Wildfly Server - Scan found incompletely copied file content for deployment - Tech Forum Network

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">