DeploymentScanner timeouts on OpenShift JBoss AS7

I haven’t seen this error often on the hosted OpenShift service (only occasionally when there’d been a system update and your app doesn’t redeploy correctly once restarted), but running OpenShift Origin locally I was seeing this consistently trying to deploy a new application:

2012/07/25 15:00:24,158 ERROR [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 1) JBAS015052: Did not receive a response to the deployment operation within the allowed timeout period [60 seconds]. Check the server configuration file and the server logs to find more about the status of the deployment.
2012/07/25 15:00:24,160 INFO  [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS015870: Deploy of deployment "ROOT.war" was rolled back with failure message Operation cancelled

To increase the deployment scanner’s timeout setting, edit your project’s .openshift/config/standalone.xml, and find the deployment-scanner element:

<subsystem xmlns="urn:jboss:domain:deployment-scanner:1.1">
            <deployment-scanner path="deployments" relative-to="jboss.server.base.dir" scan-interval="5000" />
        </subsystem>

…and then add this attribute to <deployment-scanner> :

deployment-timeout="1200"

The XSD schema for this element says the default value is 600 second, but the error above says it’s timing out after 60 seconds. Assuming the default value is 600, I doubled it, and this fixed my timeout issues.

(Page views: 2440)

6 response on “DeploymentScanner timeouts on OpenShift JBoss AS7

  1. I have increased to 1200 sec.Still i am having the same problem.Could you please let me know how to resolve this issue.

Leave a Reply